Welcome, Guest
Username: Password: Remember me
Discussion about the Yendif Event Booking & Management extension.

TOPIC: Status Language on Emails

Status Language on Emails 4 months 3 weeks ago #1151

  • jake7
  • jake7's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
We are using offline payment type for our event bookings which mean on the booking confirmation emails the status shows as 'blocked'.
My client would like this message removed as it is confusing for his clients as it seems the booking has not been made.
I've tried updating the Language files for the component but this does not change the Status message on the confirmation emails as they still are worded as 'blocked'.

How can we change this or remove status message completely.
The administrator has disabled public write access.

Status Language on Emails 4 months 3 weeks ago #1152

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 187
  • Thank you received: 32
  • Karma: 4
- Open {root}/administrator/components/com_yendifevents/libraries/mailer.php

- Search for "$item->status" and change it to ($item->status != 'blocked') ? $item->status : "REPLACE_THIS_WITH_YOUR_CUSTOM_STATUS_TEXT"

- Save the changes and try now.

Hope, this solved your issue.
Last Edit: 4 months 3 weeks ago by Super User.
The administrator has disabled public write access.
The following user(s) said Thank You: jake7

Status Language on Emails 4 months 3 weeks ago #1153

  • jake7
  • jake7's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Thanks for the help.

I've removed the following table row so the status message doesn't appear at all:

$message .= '<tr>';
$message .= '<td><strong>'.JText::_('YENDIF_EVENTS_STATUS').'</strong></td>';
$message .= '<td>'.$item->status.'</td>';
$message .= '</tr>';
The administrator has disabled public write access.
Time to create page: 0.111 seconds